summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2020-12-11 11:52:25 +0100
committerDaniel Schürmann <daschuer@mixxx.org>2020-12-11 11:52:25 +0100
commit37099e0cf92c13b79cea5e8f182bff84fea46b92 (patch)
treee11fe8eaae2987c478b8fbd15b65f89f46e684a9 /CMakeLists.txt
parent47ea2329b7db47256c4efda9257f32493023a47e (diff)
Adjust warning for udev installation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 11 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 29ef4eb506..32ac767d86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1294,10 +1294,17 @@ if(UNIX AND NOT APPLE)
DESTINATION
"${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d"
)
- message(WARNING "Installing udev rules to ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d, "
- "which is reserved for user-installed files. The correct directory for "
- "system rules is /lib/udev/rules.d. with a appropiated priority prefix. "
- "Adjust your package script accordingly and set -DINSTALL_USER_UDEV_RULES=OFF")
+ message(WARNING
+"The udev rule file for USB HID and Bulk controller permissions will be installed to "
+"${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d "
+"If you are installing Mixxx from source for your own use, copy "
+"mixxx-usb-uaccess.rules "
+"to /etc/udev/rules.d/ and run: "
+"udevadm control --reload-rules && udevadm trigger "
+"as root to load the rules. "
+"If you are building a package for a distribution, the correct directory for"
+"system rules is /lib/udev/rules.d with an appropriate priority prefix. "
+"Adjust your package script accordingly and set -DINSTALL_USER_UDEV_RULES=OFF")
endif()
endif()