summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBe <be@mixxx.org>2020-11-15 18:49:14 -0600
committerBe <be@mixxx.org>2020-11-15 19:08:25 -0600
commit32f242c10574e16713f4db0f188ea391421a20bf (patch)
treeefdf4285acd372e0196486345c545f32c9170f6c /CMakeLists.txt
parent3838247eed3b2c89a5578ec2484a75c9ea227095 (diff)
CMake: fix TagLib linking on macOS
The old module relied on the taglib-config script that taglib's build system writes hardcoded absolute paths into. That was problematic for the macOS build environment which required replacing those absolute paths before building. This new CMake module does not require modifying any taglib files.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8fc17dc634..74c79e29c5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1924,9 +1924,8 @@ else()
endif()
# TagLib
-find_package(Taglib REQUIRED)
-target_include_directories(mixxx-lib SYSTEM PUBLIC ${TAGLIB_INCLUDE_DIRS})
-target_link_libraries(mixxx-lib PUBLIC ${TAGLIB_LIBRARIES})
+find_package(TagLib REQUIRED)
+target_link_libraries(mixxx-lib PUBLIC TagLib::TagLib)
if(WIN32 AND STATIC_DEPS)
target_compile_definitions(mixxx-lib PUBLIC TAGLIB_STATIC)
endif()