summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-27 15:00:41 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-11-27 15:52:42 +0100
commit25165146e00a3734e4693855b22c07140fd70105 (patch)
treeb1d063744984683abd92300bd07a5dea109e12ec /CMakeLists.txt
parentb8ff1ba3f2f1430f22e333f6d9a9936c5f7411c6 (diff)
CMake: Fix usage of static protobuf libraries on Windows
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 454bc40a62..7cc3a7895a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1640,11 +1640,12 @@ target_include_directories(mixxx-lib SYSTEM PUBLIC ${PortMidi_INCLUDE_DIRS})
target_link_libraries(mixxx-lib PUBLIC ${PortMidi_LIBRARIES})
# Protobuf
+if(STATIC_DEPS)
+ set(Protobuf_USE_STATIC_LIBS ON)
+ mark_as_advanced(Protobuf_USE_STATIC_LIBS)
+endif()
add_subdirectory(src/proto)
target_link_libraries(mixxx-lib PUBLIC mixxx-proto)
-if(WIN32 AND NOT STATIC_DEPS)
- target_compile_definitions(mixxx-lib PUBLIC PROTOBUF_USE_DLLS)
-endif()
# Rigtorp SPSC Queue
# https://github.com/rigtorp/SPSCQueue