summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2020-04-28 15:32:31 +0200
committerGitHub <noreply@github.com>2020-04-28 15:32:31 +0200
commit0b2e0088fe058738d88de53be72680970660851f (patch)
treea0a8e0a1e1acbfa0e58569794a3863188ddc4b0b /CMakeLists.txt
parente4bb502379639aa7b543861b0f8180feb033e592 (diff)
parentae92885140385477f035f6fbf154d7b4804c7368 (diff)
Merge pull request #2689 from Be-ing/keyfinder
add KeyFinder analyzer
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0a4c58adba..08f1abfb54 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1313,6 +1313,15 @@ endif()
target_include_directories(mixxx-lib SYSTEM PUBLIC lib/fidlib)
target_link_libraries(mixxx-lib PUBLIC fidlib)
+# KeyFinder
+find_package(KeyFinder)
+option(KEYFINDER "KeyFinder" OFF)
+if(KEYFINDER)
+ target_sources(mixxx-lib PRIVATE src/analyzer/plugins/analyzerkeyfinder.cpp)
+ target_compile_definitions(mixxx-lib PUBLIC __KEYFINDER__)
+ target_link_libraries(mixxx-lib PUBLIC KeyFinder::KeyFinder)
+endif()
+
# FLAC
find_package(FLAC REQUIRED)
target_link_libraries(mixxx-lib PUBLIC FLAC::FLAC)