summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorUwe Klotz <uklotz@mixxx.org>2020-12-12 13:17:32 +0100
committerUwe Klotz <uklotz@mixxx.org>2020-12-12 13:17:51 +0100
commit02c7d73bdd38785c26a77a6be48094d349a5cabf (patch)
tree680ef65ebb8e886b8aa533299480ae537cc07f95 /CMakeLists.txt
parent18f698dffece85b0897c62f65020704ef2c2aeef (diff)
Allow to disable -pipe build option
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47e08aa713..9a737f7984 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -57,9 +57,12 @@ endif()
set(CMAKE_CXX_STANDARD 17)
-# Speed up builds on HDDs
+# Speed up builds on HDDs and prevent wearing of SDDs
if(GNU_GCC OR LLVM_CLANG)
- add_compile_options(-pipe)
+ option(BUILD_LOW_MEMORY "Store temporary build files on disk on low-memory systems" OFF)
+ if(NOT BUILD_LOW_MEMORY)
+ add_compile_options(-pipe)
+ endif()
endif()
# Profiling