summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2021-01-28 13:54:00 +0100
committerDaniel Schürmann <daschuer@mixxx.org>2021-01-28 13:54:00 +0100
commitb1982397ac3ffb4c240bfec987f77f228aa0df36 (patch)
tree65aaece32b10391df62d97acf430f37334408b8d /CMakeLists.txt
parentf1dc6c7dea0c9a3bdd75c88d3cc0af8073df7e0e (diff)
Exclude libshout 2.4.4 and 2.4.5 as well because of bug lp1913579
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5497717caf..94509b6623 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2312,12 +2312,15 @@ option(BROADCAST "Live Broadcasting (Shoutcast) support" ON)
if(BROADCAST)
find_package(Shout)
if(UNIX AND NOT APPLE)
- # Check if system lib is at least 2.4.4 and not suffering bug
+ # Check if system lib is at least 2.4.6 and not suffering bugs
# https://bugs.launchpad.net/mixxx/+bug/1833225
+ # https://bugs.launchpad.net/mixxx/+bug/1913579
if(Shout_FOUND AND Shout_VERSION VERSION_LESS 2.4.4)
- message(STATUS "Installed libshout version: ${Shout_VERSION} is suffering from bug lp1833225")
+ message(STATUS "Installed libshout version: ${Shout_VERSION} is suffering from bugs lp1833225 and lp1913579")
+ elseif(Shout_FOUND AND Shout_VERSION VERSION_LESS 2.4.6)
+ message(STATUS "Installed libshout version: ${Shout_VERSION} is suffering from bug lp1913579")
endif()
- if(NOT Shout_FOUND OR Shout_VERSION VERSION_LESS 2.4.4)
+ if(NOT Shout_FOUND OR Shout_VERSION VERSION_LESS 2.4.6)
# Fall back to internal libraray in the lib tree
message(STATUS "Using internal libshout")
add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/lib/libshout")