summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-12-22 23:12:38 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-12-25 20:07:25 +0100
commit8905e05536d287d7b83a404fb0fdc0966eb2d519 (patch)
treef7926e47a23327f3431d13a877c9935959198c46 /CMakeLists.txt
parent2559410e9423d556ba928c73164684edb98826c4 (diff)
CMake: Print message regarding udev rules during installation
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt27
1 files changed, 14 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3f02b83ba3..0b37f9bd7c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1321,19 +1321,20 @@ if(UNIX AND NOT APPLE)
DESTINATION
"${MIXXX_INSTALL_DATADIR}/udev/rules.d"
)
- message(WARNING
- " The udev rule file for USB HID and Bulk controller permissions will\n"
- " be installed to:\n"
- " ${CMAKE_INSTALL_PREFIX}/${MIXXX_INSTALL_DATADIR}/udev/rules.d.\n"
- " If you are installing Mixxx from source for your own use, copy\n"
- " mixxx-usb-uaccess.rules to /etc/udev/rules.d/ and run:\n"
- " udevadm control --reload-rules && udevadm trigger\n"
- " as root to load the rules.\n"
- " If you are building a package for a distribution, the correct\n"
- " directory for system rules is either /lib/udev/rules.d (e.g. Debian, "
- " Fedora) or /usr/lib/udev/rules.d (e.g. Arch Linux) with an appropriate\n"
- " priority prefix. Adjust your package script accordingly and set\n"
- " -DINSTALL_USER_UDEV_RULES=OFF")
+ install(CODE "
+ message(STATUS \"Important Note: Installation of udev rules\n\"
+ \"The udev rule file for USB HID and Bulk controller permissions will be\n\"
+ \"installed to:\n\"
+ \" ${CMAKE_INSTALL_PREFIX}/${MIXXX_INSTALL_DATADIR}/udev/rules.d.\n\"
+ \"If you are installing Mixxx from source for your own use, copy\n\"
+ \"mixxx-usb-uaccess.rules to /etc/udev/rules.d/ and run:\n\"
+ \" udevadm control --reload-rules && udevadm trigger\n\"
+ \"as root to load the rules.\n\"
+ \"If you are building a package for a distribution, the correct directory for\n\"
+ \"system rules is either /lib/udev/rules.d (e.g. Debian, Fedora) or\n\"
+ \"/usr/lib/udev/rules.d (e.g. Arch Linux) with an appropriate priority prefix.\n\"
+ \"Adjust your package script accordingly and set -DINSTALL_USER_UDEV_RULES=OFF\")
+ ")
endif()
endif()