summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Schürmann <daschuer@mixxx.org>2021-01-31 01:18:56 +0100
committerDaniel Schürmann <daschuer@mixxx.org>2021-01-31 01:18:56 +0100
commit82ec841a4310d43f353323544eef4c00d68cce74 (patch)
treeb8c51c276ef692650b24181a9bac426aaeb27212 /CMakeLists.txt
parentbe0b0d20f971d25c38d61c20f4d58c3214d9e310 (diff)
parent4dbe44c3d58e13d4dd968e14a2a1b222a4b240c4 (diff)
Merge remote-tracking branch 'upstream/2.3' into fdkaac-encoder3
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 92daa03281..334abc8e36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2313,12 +2313,15 @@ endif()
option(BROADCAST "Live Broadcasting (Shoutcast) support" ON)
if(BROADCAST)
find_package(Shoutidjc)
- # Check if system lib is at least 2.4.4 and not suffering bug
+ # Check if system lib is at least 2.4.6 and not suffering bugs
# https://bugs.launchpad.net/mixxx/+bug/1833225
+ # https://bugs.launchpad.net/mixxx/+bug/1913579
if(Shoutidjc_FOUND AND Shoutidjc_VERSION VERSION_LESS 2.4.4)
message(STATUS "Installed libshout-idjc version: ${Shoutidjc_VERSION} is suffering from bug lp1833225")
+ elseif(Shoutidjc_FOUND AND Shoutidjc_VERSION VERSION_LESS 2.4.6)
+ message(STATUS "Installed libshout version: ${Shout_VERSION} is suffering from bug lp1913579")
endif()
- if(NOT Shoutidjc_FOUND OR Shoutidjc_VERSION VERSION_LESS 2.4.4)
+ if(NOT Shsoutidjc_FOUND OR Shoutidjc_VERSION VERSION_LESS 2.4.6)
# Fall back to internal libraray in the lib tree
message(STATUS "Using internal libshout-idjc")
add_subdirectory("${CMAKE_CURRENT_SOURCE_DIR}/lib/libshout-idjc")