summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-12-17 02:57:58 +0100
committerJan Holthuis <jan.holthuis@ruhr-uni-bochum.de>2020-12-17 23:32:07 +0100
commit8232df33414e826c742eb34427c9d0788d143cac (patch)
treea86141d70cd69f51968e01894a35a5a5199e4148 /CMakeLists.txt
parentaa48cf49a2781c4127d43713f9b0dd332a93bb3a (diff)
CMake: Install udev rules to /usr/lib/udev/rules.d
The /etc directory is for user-data, not package data. Also, our current usage doesn't work with -DCMAKE_INSTALL_PREFIX=/usr because it's installed to /usr/etc/udev/rules.d in that case.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9227ace8b6..abe27e2c9d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1319,11 +1319,11 @@ if(UNIX AND NOT APPLE)
FILES
"${CMAKE_CURRENT_SOURCE_DIR}/res/linux/mixxx-usb-uaccess.rules"
DESTINATION
- "${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d"
+ "lib/udev/rules.d"
)
message(WARNING
" The udev rule file for USB HID and Bulk controller permissions will\n"
- " be installed to: ${CMAKE_INSTALL_SYSCONFDIR}/udev/rules.d.\n"
+ " be installed to: ${CMAKE_INSTALL_PREFIX}/lib/udev/rules.d.\n"
" If you are installing Mixxx from source for your own use, copy\n"
" mixxx-usb-uaccess.rules to /etc/udev/rules.d/ and run:\n"
" udevadm control --reload-rules && udevadm trigger\n"