summaryrefslogtreecommitdiffstats
path: root/testing/Cargo.toml
diff options
context:
space:
mode:
authorManos Pitsidianakis <el13635@mail.ntua.gr>2019-09-23 09:36:46 +0300
committerManos Pitsidianakis <el13635@mail.ntua.gr>2019-09-23 09:36:46 +0300
commit5a53020f3d2d7819c5c24871d2dd126c5a2ec84c (patch)
tree08a6b87f892811da885bd46c5c061d808a1c1b13 /testing/Cargo.toml
parent26e4d50b402213c07c7d492ace8d6cd2e88a816d (diff)
Add debug-tracing feature to all crates
The feature needs to be defined in all manifests in order to be enabled in all crates.
Diffstat (limited to 'testing/Cargo.toml')
-rw-r--r--testing/Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/Cargo.toml b/testing/Cargo.toml
index 249c3968..21047b6d 100644
--- a/testing/Cargo.toml
+++ b/testing/Cargo.toml
@@ -16,7 +16,12 @@ path = "src/linebreak.rs"
name = "imapconn"
path = "src/imap_conn.rs"
-
[dependencies]
-melib = { path = "../melib", version = "*" }
+melib = { path = "../melib", version = "*", features = ["debug-tracing"] }
text_processing = { path = "../text_processing", version = "*" }
+
+[features]
+default = []
+
+# Print tracing logs as meli runs
+debug-tracing = []