summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..ed1760b
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,12 @@
+# nix requires using nix-shell since native-tls requires pkg-config to
+# configure openssl
+#
+# See also:
+# https://nixos.wiki/wiki/C#pkg-config
+# https://github.com/NixOS/nixpkgs/issues/64530
+with import <nixpkgs> {};
+stdenv.mkDerivation {
+ name = "mastodon-async";
+ nativeBuildInputs = [ pkg-config ];
+ buildInputs = [ openssl ];
+} \ No newline at end of file