summaryrefslogtreecommitdiffstats
path: root/rust/kernel/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'rust/kernel/Cargo.toml')
-rw-r--r--rust/kernel/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/rust/kernel/Cargo.toml b/rust/kernel/Cargo.toml
new file mode 100644
index 000000000000..24ccb0912410
--- /dev/null
+++ b/rust/kernel/Cargo.toml
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+
+[package]
+name = "kernel"
+version = "0.1.0"
+authors = ["Rust for Linux Contributors"]
+edition = "2018"
+
+[dependencies]
+bitflags = "1"
+
+[build-dependencies]
+bindgen = "0.54"
+shlex = { path = "../shlex" }
+