summaryrefslogtreecommitdiffstats
path: root/drivers/char/rust_example/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/char/rust_example/Cargo.toml')
-rw-r--r--drivers/char/rust_example/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/drivers/char/rust_example/Cargo.toml b/drivers/char/rust_example/Cargo.toml
new file mode 100644
index 000000000000..c4adcdf3458a
--- /dev/null
+++ b/drivers/char/rust_example/Cargo.toml
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0
+
+# No need for details like `authors` here -- that goes in the modinfo
+# via the `kernel_module!` macro
+[package]
+name = "rust_example"
+version = "0.1.0"
+edition = "2018"
+
+[lib]
+crate-type = ["staticlib"]
+
+[dependencies]
+kernel = { path = "../../../rust/kernel" }
+