summaryrefslogtreecommitdiffstats
path: root/rust/module/Cargo.toml
diff options
context:
space:
mode:
authorMiguel Ojeda <miguel.ojeda.sandonis@gmail.com>2020-09-12 14:38:29 +0200
committerMiguel Ojeda <miguel.ojeda.sandonis@gmail.com>2020-09-12 17:06:06 +0200
commit493d0d6440128a42b81fa4797212bf5966b9f54f (patch)
treeaf64a01138b2baa7454b4448168e0ef999a775a2 /rust/module/Cargo.toml
parente280b81cab4477f0709e9f519c86944af44a913c (diff)
Parameter support
To have more flexibility, switch to a procedural macro instead. Signed-off-by: Miguel Ojeda <miguel.ojeda.sandonis@gmail.com>
Diffstat (limited to 'rust/module/Cargo.toml')
-rw-r--r--rust/module/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/rust/module/Cargo.toml b/rust/module/Cargo.toml
new file mode 100644
index 000000000000..c61e6d2c192c
--- /dev/null
+++ b/rust/module/Cargo.toml
@@ -0,0 +1,12 @@
+# SPDX-License-Identifier: GPL-2.0
+
+[package]
+name = "module"
+version = "0.1.0"
+authors = ["Rust for Linux Contributors"]
+edition = "2018"
+publish = false
+
+[lib]
+proc-macro = true
+