summaryrefslogtreecommitdiffstats
path: root/rust/kernel/Cargo.toml
diff options
context:
space:
mode:
authorMiguel Ojeda <ojeda@users.noreply.github.com>2020-09-12 15:37:03 +0200
committerGitHub <noreply@github.com>2020-09-12 15:37:03 +0200
commite280b81cab4477f0709e9f519c86944af44a913c (patch)
treec9ab0fd92d707e3f3006c9f0c032928b9c4a1ee8 /rust/kernel/Cargo.toml
parentd012a7190fc1fd72ed48911e77ca97ba4521bccd (diff)
parent0a99f235bd70ef6a8e5bed61e17f312b9839db56 (diff)
Merge pull request #4 from Rust-for-Linux/rust-initial
Initial Rust support
Diffstat (limited to 'rust/kernel/Cargo.toml')
-rw-r--r--rust/kernel/Cargo.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/rust/kernel/Cargo.toml b/rust/kernel/Cargo.toml
new file mode 100644
index 000000000000..d7f6b5aa375d
--- /dev/null
+++ b/rust/kernel/Cargo.toml
@@ -0,0 +1,16 @@
+# SPDX-License-Identifier: GPL-2.0
+
+[package]
+name = "kernel"
+version = "0.1.0"
+authors = ["Rust for Linux Contributors"]
+edition = "2018"
+publish = false
+
+[dependencies]
+bitflags = "1"
+
+[build-dependencies]
+bindgen = "0.54"
+shlex = { path = "../shlex" }
+