summaryrefslogtreecommitdiffstats
path: root/server/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'server/Cargo.toml')
-rw-r--r--server/Cargo.toml25
1 files changed, 17 insertions, 8 deletions
diff --git a/server/Cargo.toml b/server/Cargo.toml
index 43933e53..52a9bae8 100644
--- a/server/Cargo.toml
+++ b/server/Cargo.toml
@@ -8,15 +8,17 @@ edition = "2018"
lto = true
[dependencies]
-diesel = { version = "1.4.2", features = ["postgres","chrono", "r2d2", "64-column-tables"] }
+diesel = { version = "1.4.4", features = ["postgres","chrono","r2d2","64-column-tables","serde_json"] }
diesel_migrations = "1.4.0"
dotenv = "0.15.0"
-bcrypt = "0.7.0"
-activitypub = "0.2.0"
-chrono = "0.4.7"
+activitystreams = "0.6.2"
+activitystreams-new = { git = "https://git.asonix.dog/asonix/activitystreams-sketch" }
+activitystreams-ext = { git = "https://git.asonix.dog/asonix/activitystreams-ext" }
+bcrypt = "0.8.0"
+chrono = { version = "0.4.7", features = ["serde"] }
+serde_json = { version = "1.0.52", features = ["preserve_order"]}
failure = "0.1.8"
-serde_json = "1.0.52"
-serde = "1.0.105"
+serde = { version = "1.0.105", features = ["derive"] }
actix = "0.9.0"
actix-web = "2.0.0"
actix-files = "0.2.1"
@@ -35,9 +37,16 @@ lettre_email = "0.9.4"
sha2 = "0.8.1"
rss = "1.9.0"
htmlescape = "0.3.1"
+url = { version = "2.1.1", features = ["serde"] }
config = {version = "0.10.1", default-features = false, features = ["hjson"] }
percent-encoding = "2.1.0"
attohttpc = { version = "0.14.0", default-features = false, features = ["tls-rustls"] }
comrak = "0.7"
-tokio = "0.2.20"
-futures = "0.3.4"
+openssl = "0.10"
+http = "0.2.1"
+http-signature-normalization = "0.5.1"
+base64 = "0.12.1"
+tokio = "0.2.21"
+futures = "0.3.5"
+itertools = "0.9.0"
+uuid = { version = "0.8", features = ["serde", "v4"] }