summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2014-01-01 23:10:00 -0600
committerNicolas Williams <nico@cryptonector.com>2014-01-01 23:10:00 -0600
commit106fdf5114b639c6b5e97e317b857da3a58b6233 (patch)
treeae5c016391bf9773e2fb9007b7d63450cf0d2090 /configure.ac
parent99f170adc368fcbf3f1f2226660543aa7974f054 (diff)
Fix #201; check that bison accepts --warnings
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e1e08fc..e9a069fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,17 @@ AM_PROG_CC_C_O
dnl couldn't use AM_PROG_LEX as it doesn't support header files like the
dnl AC_PROG_YACC macros...
+dnl check bison version
+AC_MSG_CHECKING([bison version])
+if test "$YACC" != "bison -y"; then
+ AC_MSG_RESULT([not bison])
+elif $YACC --help | grep -- --warnings >/dev/null; then
+ AC_MSG_RESULT([ok])
+else
+ AC_MSG_RESULT([no])
+ AC_MSG_ERROR([You need bison version 2.5 or more recent.])
+fi
+
dnl
dnl these program checks should probably be deleted
dnl