summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-06-23 12:10:58 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-06-23 12:10:58 +0100
commit8630fb02bbb3c52409a4aaf682109e57a6642296 (patch)
tree72d3e5e0cc45c3b3f15272ecc5d43d3bb28176f2 /configure.ac
parent5052ab4e2b031b7a9ad227e8e8b88c3cc54c7d18 (diff)
Use libtool's built-in symbol exporting rather than a mapfile.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 0 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index a4def6aa..fad6221a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,30 +13,6 @@ AC_PROG_YACC
AC_OBJEXT
AC_EXEEXT
LT_INIT([shared static win32-dll])
-AM_CONDITIONAL(ENABLE_SHARED, test "$enable_shared" = "yes")
-
-AC_MSG_CHECKING([if libraries can be versioned])
-GLD=`$LD --help < /dev/null 2>/dev/null | grep version-script`
-if test "$GLD"; then
- have_ld_version_script=yes
- AC_MSG_RESULT(yes)
-else
- have_ld_version_script=no
- AC_MSG_RESULT(no)
- AC_MSG_WARN(*** You have not enabled versioned symbols.)
-fi
-AM_CONDITIONAL(HAVE_LD_VERSION_SCRIPT, test "$have_ld_version_script" = "yes")
-
-if test "$have_ld_version_script" = "yes"; then
- AC_MSG_CHECKING([for symbol prefix])
- SYMBOL_PREFIX=`echo "PREFIX=__USER_LABEL_PREFIX__" \
- | ${CPP-${CC-gcc} -E} - 2>&1 \
- | ${EGREP-grep} "^PREFIX=" \
- | ${SED-sed} "s:^PREFIX=::"`
- AC_SUBST(SYMBOL_PREFIX)
- AC_MSG_RESULT($SYMBOL_PREFIX)
-fi
-
AM_PROG_CC_C_O
dnl couldn't use AM_PROG_LEX as it doesn't support header files like the