summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLee Thompson <thompson@dtosolutions.com>2012-11-27 16:02:59 -0600
committerLee Thompson <thompson@dtosolutions.com>2012-11-27 16:02:59 -0600
commit006357f954c72bf4212bbc16e869efbfe9d06eda (patch)
treea4aaa7c96e0ca2f16df73eb3e797be1ef7042d34 /configure.ac
parenta33c6f3df9d84baf7d2e299e2f0441afea2bd2ec (diff)
initial attempt at autoconf implementation, removed all generated code from git
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac66
1 files changed, 66 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 00000000..09997385
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,66 @@
+AC_INIT([jq], m4_esyscmd([tr -d '\n' <VERSION]), [mu@netsoc.tcd.ie],
+ [jq], [http://stedolan.github.com/jq/])
+
+dnl Created autoconf implementation thompson@dtosolutions, 26NOV12
+AC_PREREQ([2.61])
+AC_CONFIG_AUX_DIR([config])
+AM_INIT_AUTOMAKE([parallel-tests])
+AC_PROG_CC
+AC_PROG_CC_STDC
+AC_PROG_CPP_WERROR
+
+AM_PROG_CC_C_O
+
+dnl CFLAGS is concidered a packagers variable, not a developer variable
+dnl in Auto-tools. For developer ease of use, CFLAGS are set how the
+dnl developers like them by default but the packager can disable if so
+dnl desired. This is useful if something other than gcc is needed or
+dnl for distros that need to heavily tweek the compiler (gentoo, ARM cpu
+dnl linux's, etc)
+AC_ARG_ENABLE([devcflags],
+ [AC_HELP_STRING([--enable-devcflags=@<:@yes/no@:>@],
+ [Enable the same CFLAGS used by jq developers @<:@default=yes@:>@])],
+ [enable_devcflags=$enableval],
+ [enable_devcflags=yes])
+AC_MSG_RESULT($enable_devcflags)
+dnl AM_CONDITIONAL(DEVCFLAGS, test x$enable_devcflags = xyes)
+if test "$enable_devcflags" = "yes"; then
+ AM_CONDITIONAL(DEVCFLAGS_ENABLED, true)
+fi
+
+dnl Check for sed
+AC_CHECK_PROGS(regex_cmd, sed)
+if test x$regex_cmd = "x" ; then
+ AC_MSG_NOTICE([sed is required to patch jq.])
+fi
+
+dnl Check for flex
+AC_CHECK_PROGS(flex_cmd, flex)
+if test x$flex_cmd = "x" ; then
+ AC_MSG_NOTICE([flex is required to patch jq.])
+fi
+
+dnl Check for bison
+AC_CHECK_PROGS(bison_cmd, bison)
+if test x$bison_cmd = "x" ; then
+ AC_MSG_NOTICE([bison is required to patch jq.])
+fi
+
+ AC_CONFIG_HEADERS(config.h)
+
+dnl Check for python
+AC_CHECK_PROGS(python_cmd, python)
+if test x$python_cmd = "x" ; then
+ AC_MSG_NOTICE([python is required to patch jq.])
+fi
+
+dnl Check for valgrind
+AC_CHECK_PROGS(valgrind_cmd, valgrind)
+if test x$valgrind_cmd = "x" ; then
+ AC_MSG_NOTICE([valgrind is required to test jq.])
+fi
+
+dnl AC_CONFIG_MACRO_DIR([m4])
+AM_INIT_AUTOMAKE([-Wall dist-bzip2 dist-zip])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT