summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 20:27:12 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 20:35:19 +0100
commite6494857fc188f50808fcf64e4f43188a455f264 (patch)
tree6e6d3e68569692e5f2a3b225de5d7180a8d93bd3 /configure.ac
parent12d2d4d1f53f7f1c6d53d0eb82672cdbd75a6df9 (diff)
Add some build instructions for how to install doc dependencies.
jq can now build without Ruby, but you won't get a nice manpage.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 12 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 32ecdf7b..0ad893af 100644
--- a/configure.ac
+++ b/configure.ac
@@ -34,19 +34,28 @@ fi
dnl Don't attempt to build docs if there's no Ruby lying around
-AC_ARG_ENABLE([docs],
+AC_ARG_ENABLE([docs],
AC_HELP_STRING([--disable-docs], [don't build docs]))
AS_IF([test "x$enable_docs" != "xno"],[
- AC_CHECK_PROG(bundle_cmd, bundle)
+ AC_CHECK_PROGS(bundle_cmd, bundle)
AS_IF([test "x$bundle_cmd" = "x" || \
- ! ( cd ${srcdir}/docs; bundle check 2>/dev/null )],[
+ ! ( cd ${srcdir}/docs; "$bundle_cmd" check 2>/dev/null )],[
AC_MSG_WARN([no bundler])
+ cat <<EOF
+*****************************************************************
+* Ruby dependencies for building jq documentation not found. *
+* You can still build, install and hack on jq, but the manpage *
+* will not be rebuilt and some of the tests won't run. *
+* See docs/README.md for how to install the docs dependencies. *
+*****************************************************************
+EOF
enable_docs=no
])
])
AM_CONDITIONAL([ENABLE_DOCS], [test "x$enable_docs" != xno])
+AC_SUBST([BUNDLER], ["$bundle_cmd"])
dnl AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_HEADERS(config.h)