summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 01:50:20 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 01:50:20 +0100
commit282667bbd408824af6c6fdac46cd16530f591983 (patch)
treee0d9e97c367765656961f1d21715cfa1aef0b378 /Makefile.am
parent63b689bf5430ba82bede270999371795a90a5f39 (diff)
Script for cross-compiling jq binaries for other platforms.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 58250496..f6fe3a6d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@ AM_CFLAGS = -Wextra -Wall -Wno-missing-field-initializers \
# header file creation so we'll use good old make
BUILT_SOURCES = lexer.h lexer.c parser.h parser.c
lexer.c: lexer.l
- flex -o lexer.c --header-file=lexer.h lexer.l
+ flex -o lexer.c --header-file=lexer.h $<
lexer.h: lexer.c
# Tell YACC (bison) autoconf macros that you want a header file created.
@@ -54,6 +54,10 @@ docs/site.yml: configure.ac
sed 's/^jq_version: .*/jq_version: $(VERSION)/' $@ > $@.new
mv $@.new $@
+install-binaries: $(BUILT_SOURCES)
+ $(MAKE) $(AM_MAKEFLAGS) install-exec
+
+
# setup is only used by distribution developers, not package developers.
# Still, as a matter of allowing patching, its not a bad idea to distribute
# the developer setup script in the tarball.