summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 15:22:38 +0100
committerStephen Dolan <mu@netsoc.tcd.ie>2013-05-09 15:22:38 +0100
commit12d2d4d1f53f7f1c6d53d0eb82672cdbd75a6df9 (patch)
treec75b8a9be7f5c67b8e2ef34183576ae0c76748e9 /Makefile.am
parentd75414bc94ee1e9ba74336350755df60330edbe7 (diff)
Don't build the manpage unless there's a working Ruby setup.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index abf32376..96a885c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -49,8 +49,19 @@ TEST_LOG_COMPILER = ${srcdir}/tests/run
### Building the manpage
man_MANS = jq.1
+.PHONY: real_docs
+if ENABLE_DOCS
jq.1: $(srcdir)/docs/content/3.manual/manual.yml
( cd ${abs_srcdir}/docs; rake manpage ) > $@ || { rm -f $@; false; }
+real_docs:
+ true
+else
+jq.1: jq.1.default
+ cp $^ $@
+real_docs:
+ @echo "Cannot build full manpage" > /dev/stderr
+ false
+endif
@@ -63,6 +74,8 @@ docs/site.yml: configure.ac
install-binaries: $(BUILT_SOURCES)
$(MAKE) $(AM_MAKEFLAGS) install-exec
+# Ensure "make dist" fails when we can't build the real manpage
+dist-hook: real_docs
# setup is only used by distribution developers, not package developers.
# Still, as a matter of allowing patching, its not a bad idea to distribute