summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNicolas Williams <nico@cryptonector.com>2013-06-15 00:08:59 -0500
committerNicolas Williams <nico@cryptonector.com>2013-06-15 00:08:59 -0500
commitbbf4e05fde301bc48907ca6d485c59ae10a6467c (patch)
tree21f34165b2634bacb88e0c79a5557ee1fa01bb04 /Makefile.am
parent81e2336aceed8877f2c20a466166d5b1759136fc (diff)
Move slurp_file() into library as jv_load_file()
Needed as part of creating a libjq.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index c08ed970..7da9ccff 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,12 +2,12 @@
JQ_INCS = jq_parser.h builtin.h bytecode.h compile.h execute.h \
forkable_stack.h frame_layout.h jv.h jv_alloc.h jv_aux.h jv_dtoa.h \
- jv_parse.h jv_unicode.h locfile.h opcode.h opcode_list.h parser.y \
- jv_utf8_tables.h main.h lexer.l
+ jv_file.h jv_parse.h jv_unicode.h locfile.h opcode.h opcode_list.h \
+ parser.y jv_utf8_tables.h main.h lexer.l
-JQ_SRC = locfile.c opcode.c bytecode.c compile.c execute.c builtin.c jv.c \
- jv_parse.c jv_print.c jv_dtoa.c jv_unicode.c jv_aux.c jv_alloc.c \
- jq_test.c ${JQ_INCS}
+JQ_SRC = locfile.c opcode.c bytecode.c compile.c execute.c builtin.c \
+ jv.c jv_parse.c jv_print.c jv_dtoa.c jv_unicode.c jv_aux.c jv_file.c \
+ jv_alloc.c jq_test.c ${JQ_INCS}
### C build options
@@ -131,4 +131,4 @@ if ENABLE_DOCS
endif
clean-local: clean-local-docs
- rm -f version.h .remake-version-h \ No newline at end of file
+ rm -f version.h .remake-version-h