summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Tolnay <dtolnay@gmail.com>2015-08-22 16:20:21 -0700
committerDavid Tolnay <dtolnay@gmail.com>2015-08-22 16:20:21 -0700
commit9ec27fe3626e19aab0bfa84315387b8c27f00c5b (patch)
treec649ab4d7017021f79aa67beefdd60fba42e0c46 /Makefile.am
parent75662a4b055fccff02843ad4af4d8ab2810e9d46 (diff)
Sort source file lists in Makefile.am
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am28
1 files changed, 13 insertions, 15 deletions
diff --git a/Makefile.am b/Makefile.am
index 01e42b82..f227f41f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,13 +1,13 @@
### C source files to be built and distributed.
-LIBJQ_INCS = jq_parser.h builtin.h bytecode.h compile.h exec_stack.h \
- libm.h jv_alloc.h jv_dtoa.h jv_unicode.h locfile.h \
- opcode_list.h parser.y jv_utf8_tables.h lexer.l util.h linker.h
+LIBJQ_INCS = builtin.h bytecode.h compile.h exec_stack.h jq_parser.h \
+ jv_alloc.h jv_dtoa.h jv_unicode.h jv_utf8_tables.h lexer.l \
+ libm.h linker.h locfile.h opcode_list.h parser.y util.h
-LIBJQ_SRC = locfile.c bytecode.c compile.c execute.c builtin.c jv.c \
- jv_parse.c jv_print.c jv_dtoa.c jv_unicode.c jv_aux.c jv_file.c \
- jv_alloc.c jq_test.c util.c linker.c ${LIBJQ_INCS}
+LIBJQ_SRC = builtin.c bytecode.c compile.c execute.c jq_test.c jv.c \
+ jv_alloc.c jv_aux.c jv_dtoa.c jv_file.c jv_parse.c jv_print.c \
+ jv_unicode.c linker.c locfile.c util.c ${LIBJQ_INCS}
### C build options
@@ -148,20 +148,18 @@ DOC_FILES = docs/content docs/public docs/templates docs/site.yml \
# setup is only used by distribution developers, not package developers.
# Still, as a matter of allowing patching, its not a bad idea to distribute
# the developer setup script in the tarball.
-EXTRA_DIST = $(man_MANS) $(TESTS) $(TEST_LOG_COMPILER) jq.spec \
- $(DOC_FILES) scripts/version parser.h parser.c lexer.h \
- lexer.c tests/onig.supp tests/torture/input0.json \
- tests/modules/.jq tests/modules/a.jq tests/modules/b/b.jq \
- tests/modules/c/c.jq tests/modules/c/d.jq \
+EXTRA_DIST = $(DOC_FILES) $(man_MANS) $(TESTS) $(TEST_LOG_COMPILER) \
+ jq.1.prebuilt jq.spec lexer.c lexer.h parser.c parser.h \
+ scripts/version tests/jq.test tests/modules/.jq \
+ tests/modules/a.jq tests/modules/b/b.jq tests/modules/c/c.jq \
+ tests/modules/c/d.jq tests/modules/data.json \
tests/modules/lib/jq/e/e.jq tests/modules/lib/jq/f.jq \
- tests/setup tests/jq.test tests/onig.test \
- tests/modules/data.json \
tests/modules/syntaxerror/syntaxerror.jq \
tests/modules/test_bind_order.jq \
tests/modules/test_bind_order0.jq \
tests/modules/test_bind_order1.jq \
- tests/modules/test_bind_order2.jq \
- jq.1.prebuilt
+ tests/modules/test_bind_order2.jq tests/onig.supp \
+ tests/onig.test tests/setup tests/torture/input0.json
# README.md is expected in Github projects, good stuff in it, so we'll