summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLee Thompson <thompson@dtosolutions.com>2012-12-04 16:29:01 -0600
committerLee Thompson <thompson@dtosolutions.com>2012-12-04 16:29:01 -0600
commit76c87061455af3d8d7d0506b153c140d7ee7b62d (patch)
tree051dee38f94cffa82b4cbb00964f81e4e19600fa /Makefile.am
parent277249ffe6f1e9b70c9877d938209012e34d9726 (diff)
fix rpm mv command when rpm stashes the package in a subdirectory
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index c05f55e5..63fc5eab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,7 +70,7 @@ rpm: jq jq_test
mkdir -p rpm/SOURCES rpm/BUILD rpm/BUILDROOT rpm/RPMS rpm/SPECS
cp jq-$$(cat VERSION).tar.gz rpm/SOURCES/
rpmbuild -tb --define "_topdir ${PWD}/rpm" --define "_prefix ${HOME}" --define "version $$(cat VERSION)" --define "release ${RELEASE}" rpm/SOURCES/jq-$$(cat VERSION).tar.gz
- mv rpm/RPMS/* ./
+ find rpm/RPMS/ -name "*.rpm" -exec mv {} ./ \;
rm -rf rpm
dist-clean-local: