summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMattias Hansson <hansson.mattias@gmail.com>2019-03-29 13:25:39 +0100
committerNico Williams <nico@cryptonector.com>2019-03-29 08:16:36 -0500
commit3c4fcb1594694e15b83dc05094cd1dd61f5c7dcc (patch)
tree89592dd98487aa18b77134e771773d8eadf62df4 /Makefile.am
parentb52fc1043b045a3c5004be7eb85a15d3a055e9a4 (diff)
Add pkg-config file for libjq
pkg-config is a common interface to resolve build details. It will become easier to incorporate libjq in other projects by providing this interface.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 10d706d8..dcdb0be5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -175,6 +175,7 @@ DOC_FILES = docs/content docs/public docs/templates docs/site.yml \
EXTRA_DIST = $(DOC_FILES) $(man_MANS) $(TESTS) $(TEST_LOG_COMPILER) \
jq.1.prebuilt jq.spec src/lexer.c src/lexer.h src/parser.c \
src/parser.h src/version.h src/builtin.jq scripts/version \
+ libjq.pc \
tests/base64.test tests/jq-f-test.sh tests/jq.test \
tests/modules/a.jq tests/modules/b/b.jq tests/modules/c/c.jq \
tests/modules/c/d.jq tests/modules/data.json \
@@ -194,6 +195,9 @@ EXTRA_DIST = $(DOC_FILES) $(man_MANS) $(TESTS) $(TEST_LOG_COMPILER) \
docdir = ${datadir}/doc/${PACKAGE}
dist_doc_DATA = README.md COPYING AUTHORS README
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libjq.pc
+
RELEASE ?= 1
rpm: dist jq.spec
@echo "Packaging jq as an RPM ..."