summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Peschel <apeschel@zendesk.com>2015-06-09 16:45:06 -0700
committerNicolas Williams <nico@cryptonector.com>2015-06-09 19:01:20 -0500
commitc95b4a8ab4ace9389788bd26a181d1b7448600ec (patch)
treebd4ccf1a0b914386c6d9bab7e5320d21c1a316b2 /Makefile.am
parent520b429ca01b2ecf2d221a984e8dd9ac242c0de3 (diff)
Add Missing Makefile Dependency
main.c requires version.h, but there is no logic marking this dependency in the Makefile. This commit adds the dependency to the Makefile template.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 69da0746..97e10338 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ generate_ver = ver="`{ $(srcdir)/scripts/version || echo '$(VERSION)' ; } | sed
@ $(generate_ver); test "x`cat version.h 2>/dev/null`" = "x$$ver" || touch .remake-version-h
version.h: .remake-version-h
$(AM_V_GEN) $(generate_ver); echo "$$ver" > $@
+main.c: version.h
bin_PROGRAMS = jq
jq_SOURCES = main.c version.h