summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorCaleb Bassi <calebjbassi@gmail.com>2019-02-15 03:30:40 -0800
committerCaleb Bassi <calebjbassi@gmail.com>2019-02-15 05:20:33 -0800
commit8a48989e8a69568e850a18f5686810b7adf92b3d (patch)
tree87f7c4fd996965d1e06cf29c3be14464ecebc8d2 /Cargo.toml
parent07f03353e27eb7df9a6e0f6457dd79bfd6ff4dac (diff)
Replace clap with structopt for argument parsing
- structopt is built on top of clap and provides a convenient layer for configuring cli args - it also comes built in with `-V, --version` and `-h, --help`
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a52dc47..2010a56 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,7 +7,6 @@ homepage = "https://github.com/kamiyaa/joshuto"
license = "LGPL-3"
[dependencies]
-clap = "2.32.0"
chrono = "0.4.6"
fs_extra = "1.1.0"
lazy_static = "1.2.0"
@@ -17,6 +16,7 @@ mime-detective = { git = "https://github.com/cjbassi/mime-detective", branch = "
open = "1.2.2"
serde = "1.0.84"
serde_derive = "1.0.84"
+structopt = "0.2.14"
toml = "0.4.10"
unicode-width = "0.1.5"
whoami = "0.4.1"