summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2020-02-08 20:58:03 -0500
committerJiayi Zhao <jeff.no.zhao@gmail.com>2020-02-08 20:58:55 -0500
commit656582a6c867c25667661be9b327b4cc73859d7d (patch)
treefe03a1822b752a747da099aeb33a610fb3590067 /Cargo.toml
parent7a603efb9b3024438bdce8899fd21bcf353e3832 (diff)
change to using termion's keyboard handling
- user input is now on a seperate thread - this allows for other threads to be added as well - keymap configs have changed to be more user friendly
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 438dd17..1dc8d01 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,15 +13,16 @@ chrono = "^0"
dirs = "^1"
fs_extra = "^1"
lazy_static = "^1"
-libc = "^0.2"
+libc = "^0"
notify = "^4"
-open = "1.2.2"
+open = "^1"
rand = "^0"
-rustyline = "^4.1"
+rustyline = "^4"
serde = "^1"
serde_derive = "^1"
-structopt = "0.2.14"
+structopt = "^0"
text_io = "^0"
+termion = "*"
toml = "^0"
unicode-width = "^0"
users = "^0"