summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2019-01-24 22:03:17 -0500
committerJiayi Zhao <jeff.no.zhao@gmail.com>2019-01-24 23:40:59 -0500
commit4f25f859124b426bf25e171d20ede082b797b23f (patch)
tree1b990bc97467474f3e1b754dba05558246ea6be6 /Cargo.toml
parent18f78a89a37a24da8642f2ba794e1c180184801a (diff)
major refactoring
- moved alot of code around - move context outside joshuto.rs - fixed weird memory leak where OsStrings were not loading properly - fixed ncurses::windows getting freed multiple times - make textfield struct for dealing with user input - make use of unicode_width instead of wcwidth
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 18dcc58..87c1c13 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ open = "1.2.2"
serde = "1.0.84"
serde_derive = "1.0.84"
toml = "0.4.10"
-wcwidth = "1.0.1"
+unicode-width = "0.1.5"
whoami = "0.4.1"
xdg = "2.2.0"