summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJeff Zhao <jeff.no.zhao@gmail.com>2023-07-23 15:34:16 -0400
committerJeff Zhao <jeff.no.zhao@gmail.com>2023-07-23 15:34:16 -0400
commit715b5fbdc62caeababee1857c696d0796805c3d3 (patch)
treefafd3297f8565e804a557a0d866cc44b367b480f /Cargo.toml
parent5d2473f6e4a21eacde29067d2b3f53e5e6ee2784 (diff)
migrate to ratatui
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 6 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index d1441da..c6323e3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -10,7 +10,7 @@ edition = "2021"
keywords = ["tui-rs", "ranger", "file_manager", "termion"]
[dependencies]
-ansi-to-tui = { version = "^3", optional = true }
+ansi-to-tui = { version = "^3.1.0", optional = true }
alphanumeric-sort = "^1"
chrono = "^0"
colors-transform = "^0"
@@ -33,9 +33,6 @@ structopt = "^0"
termion = "^2"
toml = "^0"
trash = { version = "^3", optional = true }
-tui = { version = "0.21", default-features = false, features = [
- "termion",
-], package = "ratatui" }
unicode-segmentation = "^1"
unicode-width = "^0"
users = "^0"
@@ -43,6 +40,11 @@ whoami = "^1"
xdg = "^2"
walkdir = "^2"
+[dependencies.ratatui]
+version = "^0"
+default-features = false
+features = ["termion"]
+
[dependencies.uuid]
version = "^1"
features = ["v4", "fast-rng", "macro-diagnostics"]