summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAnton Simonov <asimonov215@gmail.com>2023-07-01 19:30:41 +0300
committerGitHub <noreply@github.com>2023-07-01 12:30:41 -0400
commit09bd69e4b1094f0ed9df40ce7c890e1bf55af7f4 (patch)
tree5c8982f013a7c84d176750f8af2f229f28d61491 /Cargo.toml
parent93061c472d4d735ea48bb729216bb5a61fe92a64 (diff)
Migrate termion lib from v1 to v2. Mouse feature turn on by default (#349)
* Migrate termion lib from v1 to v2 * Refactor termion with mouse support * Mouse feature is turn on by default in cargo * Refactor: simplification * Update notify to v6 stable. No problems so far * Update lib open to v5 * lib trash bump from v2 to v3 * Updated dependencies and planned migrations of 2 libs
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml13
1 files changed, 8 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 449db3e..5879ec4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -19,20 +19,23 @@ filetime = "^0"
globset = "^0"
lazy_static = "^1"
libc = "^0"
-notify = "5.0.0-pre.15"
-open = "^2"
+notify = "^6"
+open = "^5"
phf = { version = "^0", features = ["macros"], optional = true }
rand = "^0"
+# rustline latest is v12 migrate
rustyline = "^9"
serde = "^1"
serde_derive = "^1"
shell-words = "^1"
+# shellexpand latest is v3 migrate
+# shellexpand = { version = "^3", features = ["full"]}
shellexpand = "^2"
signal-hook = "^0"
structopt = "^0"
-termion = "^1"
+termion = "^2"
toml = "^0"
-trash = { version = "^2", optional = true }
+trash = { version = "^3", optional = true }
tui = { version = "0.21", default-features = false, features = [
"termion",
], package = "ratatui" }
@@ -53,4 +56,4 @@ file_mimetype = []
mouse = []
recycle_bin = ["trash"]
syntax_highlight = ["ansi-to-tui"]
-default = ["devicons", "recycle_bin", "syntax_highlight"]
+default = ["devicons", "mouse", "recycle_bin", "syntax_highlight"]