summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorDLFW <daniel@llin.info>2021-12-17 01:42:35 +0100
committerGitHub <noreply@github.com>2021-12-16 19:42:35 -0500
commitae77a0fa7594dcf1a61954d0b0e2de7aac6961ce (patch)
treeb0d72ae427c43b1f4515ea1be02cb92351de0ffa /Cargo.toml
parent2f3b4423a9e9c6f57bdf9e83052bbcda9ad121c1 (diff)
Update view on filesystem changes (#112)
* Update view on filesystem changes AppContext owns an INotifyWatcher, which watches the visible directories (max. three). The list of directories to watch is updated on every event. If a filesystem change is announced, a "soft-update" of the current view is issued. * Specific "watchers" for Linux and MacOS For supervision of filesystem changes, specific `notify::Watcher` implementations are used for Linux and MacOS. Builds will likely fail for other OSes as `notify::recommended_watcher` may return some specific watcher implementation but the code just expects a `NullWatcher`. * remove dead code
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 98a6857..abc0738 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -36,6 +36,7 @@ phf = { version = "^0", features = ["macros"], optional = true }
trash = { version = "^1", optional = true }
unicode-segmentation = "^1"
ansi-to-tui = "0.4.1"
+notify = "5.0.0-pre.13"
[features]
devicons = [ "phf" ]