summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJustin Chen <ctj12461@163.com>2023-08-25 01:28:24 +0800
committerGitHub <noreply@github.com>2023-08-24 13:28:24 -0400
commit2c4138dd165adb6043cce6633741bab9595ad687 (patch)
treed028b0e1fa2842f532ed4f15ef70153495dccaea /Cargo.toml
parent88328d90876efaec407033b96b89da48063cf055 (diff)
feat: regex support (#411)
* feat: add the regex support for the matcher * feat: add functions for searching with regex * feat: add commands for searching with regex and change the case sensitivity * docs: add explanations for the new feature
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b285561..f97d570 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -38,6 +38,7 @@ whoami = "^1"
xdg = "^2"
walkdir = "^2"
bitflags = { version = "^2", features = ["serde"] }
+regex = "1.9.3"
[dependencies.nix]
version = "^0"