summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRuixi-rebirth <ruixirebirth@gmail.com>2023-05-27 20:49:55 -0600
committerGitHub <noreply@github.com>2023-05-27 22:49:55 -0400
commit20d51cf17a5e93cc20373423efeca72fd7c100d5 (patch)
treedca1d1be6cc5a31192c8a8acccef974649e1acce /Cargo.toml
parent493af3185092036cbbae81ae620b101f66cf4e9a (diff)
Add flake support (#297)
Add flake support
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml18
1 files changed, 8 insertions, 10 deletions
diff --git a/Cargo.toml b/Cargo.toml
index caa1585..ebb6e9c 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -33,7 +33,9 @@ structopt = "^0"
termion = "^1"
toml = "^0"
trash = { version = "^2", optional = true }
-tui = { version = "0.20", default-features = false, features = ["termion"], package = "ratatui" }
+tui = { version = "0.20", default-features = false, features = [
+ "termion",
+], package = "ratatui" }
unicode-segmentation = "^1"
unicode-width = "^0"
users = "^0"
@@ -43,16 +45,12 @@ walkdir = "^2"
[dependencies.uuid]
version = "^1"
-features = [
- "v4",
- "fast-rng",
- "macro-diagnostics",
-]
+features = ["v4", "fast-rng", "macro-diagnostics"]
[features]
-devicons = [ "phf" ]
+devicons = ["phf"]
file_mimetype = []
mouse = []
-recycle_bin = [ "trash" ]
-syntax_highlight = [ "ansi-to-tui" ]
-default = [ "devicons", "recycle_bin", "syntax_highlight" ]
+recycle_bin = ["trash"]
+syntax_highlight = ["ansi-to-tui"]
+default = ["devicons", "recycle_bin", "syntax_highlight"]