summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJiayi Zhao <jeff.no.zhao@gmail.com>2019-01-02 10:58:15 -0500
committerJiayi Zhao <jeff.no.zhao@gmail.com>2019-01-02 10:58:15 -0500
commitc63bd39ceff67c14235fd2f5f0692e74c4220098 (patch)
tree04698eea6a396ca87fb355049f3cb25d13b274ad /Cargo.toml
parentd88f68a3880b8362a20999cc3e84177d3f8a3f5d (diff)
remove use of tree_magic in favour of mime_guess
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml16
1 files changed, 14 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 27e4a1e..3f8ff0d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -11,15 +11,27 @@ clap = "2.32.0"
fs_extra = "1.1.0"
lazy_static = "1.2.0"
libc = "0.2.45"
-keycodes = "0.1.0"
+mime_guess = "1.8.6"
serde = "1.0.82"
serde_derive = "1.0.82"
toml = "0.4.10"
-tree_magic = "0.2.1"
wcwidth = "1.0.1"
whoami = "0.2.4"
xdg = "2.2.0"
+# clap = "*"
+# fs_extra = "*"
+# lazy_static = "*"
+# libc = "*"
+# mime_guess = "1.8.6"
+# serde = "*"
+# serde_derive = "*"
+# toml = "*"
+# wcwidth = "*"
+# whoami = "*"
+# xdg = "*"
+
+
[dependencies.ncurses]
version = "5.97.0"
features = [ "extended_colors", "panel" ]