summaryrefslogtreecommitdiffstats
path: root/bin/domain/imag-bookmark/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'bin/domain/imag-bookmark/Cargo.toml')
-rw-r--r--bin/domain/imag-bookmark/Cargo.toml8
1 files changed, 8 insertions, 0 deletions
diff --git a/bin/domain/imag-bookmark/Cargo.toml b/bin/domain/imag-bookmark/Cargo.toml
index 7e039df1..c5851236 100644
--- a/bin/domain/imag-bookmark/Cargo.toml
+++ b/bin/domain/imag-bookmark/Cargo.toml
@@ -25,11 +25,14 @@ toml = "0.5.1"
toml-query = "0.9.2"
failure = "0.1.5"
resiter = "0.4.0"
+url = "2"
libimagrt = { version = "0.10.0", path = "../../../lib/core/libimagrt" }
libimagerror = { version = "0.10.0", path = "../../../lib/core/libimagerror" }
+libimagstore = { version = "0.10.0", path = "../../../lib/core/libimagstore" }
libimagbookmark = { version = "0.10.0", path = "../../../lib/domain/libimagbookmark" }
libimagentrylink = { version = "0.10.0", path = "../../../lib/entry/libimagentrylink" }
+libimagentryurl = { version = "0.10.0", path = "../../../lib/entry/libimagentryurl" }
libimagutil = { version = "0.10.0", path = "../../../lib/etc/libimagutil" }
[dependencies.clap]
@@ -37,6 +40,11 @@ version = "2.33.0"
default-features = false
features = ["color", "suggestions", "wrap_help"]
+[dependencies.uuid]
+version = "0.7"
+default-features = false
+features = ["serde", "v4"]
+
[lib]
name = "libimagbookmarkfrontend"
path = "src/lib.rs"