summaryrefslogtreecommitdiffstats
path: root/lib/core/libimagerror/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2020-03-07 16:16:56 +0100
committerMatthias Beyer <mail@beyermatthias.de>2020-03-08 11:43:24 +0100
commit126424630159a7aaa93f5e0de3a86d540a1f2b7c (patch)
tree8e970b8f670191a09a95345d41b792f589690fd6 /lib/core/libimagerror/Cargo.toml
parent8527d447ae2047e0d5d54cc70599a895b62a3ee0 (diff)
Move libimagerror to thiserror
In this patch, the error output (tracing) algorithm was changed, but should essentially print the same information. Signed-off-by: Matthias Beyer <mail@beyermatthias.de>
Diffstat (limited to 'lib/core/libimagerror/Cargo.toml')
-rw-r--r--lib/core/libimagerror/Cargo.toml9
1 files changed, 5 insertions, 4 deletions
diff --git a/lib/core/libimagerror/Cargo.toml b/lib/core/libimagerror/Cargo.toml
index 3b18a2f6..2cea7cbd 100644
--- a/lib/core/libimagerror/Cargo.toml
+++ b/lib/core/libimagerror/Cargo.toml
@@ -20,7 +20,8 @@ is-it-maintained-open-issues = { repository = "matthiasbeyer/imag" }
maintenance = { status = "actively-developed" }
[dependencies]
-log = "0.4.6"
-ansi_term = "0.12"
-anyhow = "1"
-
+log = "0.4.6"
+toml = "0.5"
+ansi_term = "0.12"
+thiserror = "1"
+anyhow = "1"