summaryrefslogtreecommitdiffstats
path: root/imag-notes/Cargo.toml
diff options
context:
space:
mode:
authorMatthias Beyer <mail@beyermatthias.de>2017-08-26 21:11:45 +0200
committerMatthias Beyer <mail@beyermatthias.de>2017-08-27 11:25:43 +0200
commita4c2c04c61a5de54a1f55b44c418b351b71697cc (patch)
treecbe394265fc796b183dacb90461e73f809fd197c /imag-notes/Cargo.toml
parent6ef03cda0898231f3c57416ad5e52868b01c6db5 (diff)
Use cargo feature to specify both version and path
Thanks to reddit user /u/TimNN for suggesting this.
Diffstat (limited to 'imag-notes/Cargo.toml')
-rw-r--r--imag-notes/Cargo.toml24
1 files changed, 6 insertions, 18 deletions
diff --git a/imag-notes/Cargo.toml b/imag-notes/Cargo.toml
index 9bb55aa7..e3a056bd 100644
--- a/imag-notes/Cargo.toml
+++ b/imag-notes/Cargo.toml
@@ -20,21 +20,9 @@ log = "0.3"
version = "2.0.1"
itertools = "0.5"
-[dependencies.libimagrt]
-path = "../libimagrt"
-
-[dependencies.libimagnotes]
-path = "../libimagnotes"
-
-[dependencies.libimagentryedit]
-path = "../libimagentryedit"
-
-[dependencies.libimagentrytag]
-path = "../libimagentrytag"
-
-[dependencies.libimagerror]
-path = "../libimagerror"
-
-[dependencies.libimagutil]
-path = "../libimagutil"
-
+libimagrt = { version = "0.4.0", path = "../libimagrt" }
+libimagnotes = { version = "0.4.0", path = "../libimagnotes" }
+libimagentryedit = { version = "0.4.0", path = "../libimagentryedit" }
+libimagentrytag = { version = "0.4.0", path = "../libimagentrytag" }
+libimagerror = { version = "0.4.0", path = "../libimagerror" }
+libimagutil = { version = "0.4.0", path = "../libimagutil" }