summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorrabite <rabite@posteo.de>2019-06-29 23:33:25 +0200
committerrabite <rabite@posteo.de>2019-06-29 23:33:25 +0200
commit11f5bd081bf303e96e79a9c3bd2c87855f1584e0 (patch)
tree6eabc5fc758ea220852b256a451db14fb751b1d3 /Cargo.toml
parentcd01a21f687a0d17984ee982e2e899634879db9a (diff)
modularize media preview generator into own workspace
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml29
1 files changed, 10 insertions, 19 deletions
diff --git a/Cargo.toml b/Cargo.toml
index fe35709..4a146b5 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,3 +1,5 @@
+cargo-features = ["default-run"]
+
[package]
name = "hunter"
version = "1.2.1"
@@ -10,6 +12,8 @@ readme = "README.md"
license = "WTFPL"
keywords = ["cli", "terminal", "file"]
categories = ["command-line-utilities"]
+default-run = "hunter"
+
[dependencies]
termion = "1.5.1"
@@ -36,29 +40,16 @@ pathbuftools = "0.1"
clap = "2.33"
mime = "0.3.13"
-
-
-image = { version = "0.21.1", optional = true }
-gstreamer = { version = "0.11.2", optional = true }
-gstreamer-app = { version = "0.11.2", optional = true }
-
-
-
-
[features]
-default = ["img", "video"]
-img = ["image"]
-video = ["img", "gstreamer", "gstreamer-app"]
+default = ["video"]
+video = []
+
-[[bin]]
-name = "hunter"
-path = "src/main.rs"
-[[bin]]
-name = "preview-gen"
-path = "src/preview-gen.rs"
-required-features = ["img"]
+[workspace]
+members = [".", "hunter-media"]
+default-members = [".", "hunter-media"]
[patch.crates-io]