summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorrabite <rabite@posteo.de>2019-07-08 12:53:44 +0200
committerrabite <rabite@posteo.de>2019-07-08 13:00:32 +0200
commit072b39b3cfeac109f8bb0fff747c6dc50d747942 (patch)
treeb96cbdc6e8cdcfcc214cbfcf92145cd19b00e3fc /Cargo.toml
parent9b6bb7fea092b621337e797b8fd3628ff7ad8218 (diff)
initial support for SIXEL/kitty graphics
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 05d3740..407a351 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -16,7 +16,8 @@ default-run = "hunter"
[dependencies]
-termion = "1.5.1"
+# Added terminal_size_pixels recently
+termion = { git = "https://github.com/redox-os/termion" }
unicode-width = "0.1.5"
lazy_static = "0.2.11"
alphanumeric-sort = "1.0.6"
@@ -39,13 +40,17 @@ osstrtools = "0.1.9"
pathbuftools = "0.1"
clap = "2.33"
mime = "0.3.13"
+# Updated to work with recent sixel-sys
+sixel = { git = "https://github.com/rabite0/sixel-rs", tag="v0.3.0" }
+base64 = { version = "0.10.1" }
image = { version = "0.21.1", optional = true }
gstreamer = { version = "0.11.2", optional = true }
gstreamer-app = { version = "0.11.2", optional = true }
[build-dependencies]
-termion = "1.5.1"
+# Added terminal_size_pixels recently
+termion = { git = "https://github.com/redox-os/termion" }
rustc_version = "0.2.3"
[features]