summaryrefslogtreecommitdiffstats
path: root/hwloc-1.2.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'hwloc-1.2.1/Makefile.am')
-rw-r--r--hwloc-1.2.1/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/hwloc-1.2.1/Makefile.am b/hwloc-1.2.1/Makefile.am
new file mode 100644
index 00000000..de37e341
--- /dev/null
+++ b/hwloc-1.2.1/Makefile.am
@@ -0,0 +1,27 @@
+# Copyright © 2009 INRIA. All rights reserved.
+# Copyright © 2009 Université Bordeaux 1
+# Copyright © 2009-2010 Cisco Systems, Inc. All rights reserved.
+# See COPYING in top-level directory.
+
+# Note that the -I directory must *exactly* match what was specified
+# via AC_CONFIG_MACRO_DIR in configure.ac.
+ACLOCAL_AMFLAGS = -I ./config
+
+SUBDIRS = src include
+
+# Do not let automake automatically add the non-standalone dirs to the
+# distribution tarball if we're building in embedded mode.
+DIST_SUBDIRS = $(SUBDIRS)
+
+#
+# "make distcheck" requires that tarballs are able to be able to "make
+# dist", so we have to include config/distscript.csh.
+#
+EXTRA_DIST = \
+ README VERSION COPYING AUTHORS \
+ config/hwloc_get_version.sh \
+ config/distscript.csh
+
+#
+# Build the top-level README file
+#