summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90b0e850..225c6d85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -275,3 +275,17 @@ AM_CONDITIONAL([HTOP_UNSUPPORTED], [test "$my_htop_platform" = unsupported])
AC_SUBST(my_htop_platform)
AC_CONFIG_FILES([Makefile htop.1])
AC_OUTPUT
+
+if test "$my_htop_platform" = "unsupported"
+then
+ echo ""
+ echo "****************************************************************"
+ echo "WARNING! This platform is not currently supported by htop."
+ echo ""
+ echo "The code will build, but it will produce a dummy version of htop"
+ echo "which shows no processes, using the files from the unsupported/"
+ echo "directory. This is meant to be a skeleton, to be used as a"
+ echo "starting point if you are porting htop to a new platform."
+ echo "****************************************************************"
+ echo ""
+fi