summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 01a9b266..a1a57578 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,6 +108,7 @@ AC_CHECK_HEADERS([ \
strings.h \
sys/param.h \
sys/time.h \
+ sys/utsname.h \
unistd.h
], [], [AC_MSG_ERROR([can not find required generic header files])])
@@ -189,6 +190,7 @@ AC_CHECK_FUNCS([ \
faccessat \
fstatat \
host_get_clock_service \
+ memfd_create\
openat \
readlinkat \
])
@@ -315,15 +317,17 @@ case "$enable_hwloc" in
;;
esac
-
-AC_ARG_ENABLE([setuid],
- [AS_HELP_STRING([--enable-setuid],
- [enable setuid support for privilege dropping @<:@default=no@:>@])],
- [],
- [enable_setuid=no])
-if test "x$enable_setuid" = xyes; then
- AC_DEFINE([HAVE_SETUID_ENABLED], [1], [Define if setuid support should be enabled.])
+AC_ARG_WITH([os-release],
+ [AS_HELP_STRING([--with-os-release=FILE],
+ [location of an os-release file @<:@default=/etc/os-release@:>@])],
+ [],
+ [with_os_release=/etc/os-release])
+if test -n "$with_os_release" && test ! -f "$with_os_release"; then
+ if test -f "/usr/lib/os-release"; then
+ with_os_release="/usr/lib/os-release"
+ fi
fi
+AC_DEFINE_UNQUOTED([OSRELEASEFILE], ["$with_os_release"], [File with OS release details.])
# ----------------------------------------------------------------------
@@ -569,11 +573,13 @@ fi
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug],
- [Enable asserts and internal sanity checks @<:@default=no@:>@])],
+ [Enable compiling with maximum debug info, asserts and internal sanity checks @<:@default=no@:>@])],
[],
[enable_debug=no])
if test "x$enable_debug" != xyes; then
AM_CPPFLAGS="$AM_CPPFLAGS -DNDEBUG"
+else
+ AM_CPPFLAGS="$AM_CPPFLAGS -ggdb3"
fi
@@ -618,6 +624,7 @@ AC_MSG_RESULT([
${PACKAGE_NAME} ${VERSION}
platform: $my_htop_platform
+ os-release file: $with_os_release
(Linux) proc directory: $with_proc
(Linux) openvz: $enable_openvz
(Linux) vserver: $enable_vserver
@@ -628,7 +635,6 @@ AC_MSG_RESULT([
(Linux) capabilities: $enable_capabilities
unicode: $enable_unicode
hwloc: $enable_hwloc
- setuid: $enable_setuid
debug: $enable_debug
static: $enable_static
])