summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b71a9e86..35aa254f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,6 +215,13 @@ coverage:
cppcheck:
cppcheck -q -v . --enable=all -DHAVE_CGROUP -DHAVE_OPENVZ -DHAVE_TASKSTATS
+dist-hook: $(top_distdir)/configure
+ @if grep 'pkg_m4_absent' '$(top_distdir)/configure'; then \
+ echo 'configure is generated without pkg.m4. Please supply pkg.m4 and run ./autogen.sh to rebuild the configure script.'>&2; \
+ (exit 1); \
+ else :; \
+ fi
+
.PHONY: lcov
lcov: