summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f9b9a7d4..c66aa46c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -328,6 +328,29 @@ myhtopplatheaders = $(solaris_platform_headers)
myhtopplatsources = $(solaris_platform_sources)
endif
+# Performance Co-Pilot (PCP)
+# --------------------------
+
+pcp_platform_headers = \
+ pcp/PCPProcess.h \
+ pcp/PCPProcessList.h \
+ pcp/Platform.h \
+ pcp/ProcessField.h \
+ linux/PressureStallMeter.h \
+ linux/ZramMeter.h \
+ linux/ZramStats.h
+
+if HTOP_PCP
+myhtopplatsources = \
+ pcp/PCPProcess.c \
+ pcp/PCPProcessList.c \
+ pcp/Platform.c \
+ linux/PressureStallMeter.c \
+ linux/ZramMeter.c
+
+myhtopplatheaders = $(pcp_platform_headers)
+endif
+
# Unsupported
# -----------