summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorgmbroome <thrirhrafnir@gmail.com>2018-03-02 16:20:46 -0500
committerHisham Muhammad <hisham@gobolinux.org>2018-04-06 11:13:30 -0300
commit1aa23925c9c4604072d0fb1e2d3932caf0ad9c53 (patch)
tree63754f0874385fe68e3d9520165bd9632ad2c221 /Makefile.am
parent2e1f56d934d7de475db5b6ffac0d2915088ed662 (diff)
Import Solaris support (#741)
This commit adds support for Solaris, squashed from PR #741: Summary of additions: * Initial setup of Solaris platform directory * Add Solaris platform into autoconf template * Uptime and load averages * Add dependency on libkstat * Basic process listing * Zone name display * CPU detection * Per-process memory and CPU usage parsed correctly * Uses sysconf to discover number of CPUs, instead of more complex libkstat code * Simple memory display working * Reduce repetitive calls to the PAGE_SIZE macro when reading memory info * Add Project, Contract, Task, and Pool into process properties * Use system major()/minor() implementations and remove extraneous definition of mkdev() * Get the STARTTIME column working properly, using the Linux implementation as a guide
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1aa70c27..9abfdd8f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -81,6 +81,16 @@ myhtopplatheaders = darwin/Platform.h darwin/DarwinProcess.h \
darwin/DarwinProcessList.h darwin/DarwinCRT.h darwin/Battery.h
endif
+if HTOP_SOLARIS
+myhtopplatsources = solaris/Platform.c \
+solaris/SolarisProcess.c solaris/SolarisProcessList.c \
+solaris/SolarisCRT.c solaris/Battery.c
+
+myhtopplatheaders = solaris/Platform.h \
+solaris/SolarisProcess.h solaris/SolarisProcessList.h \
+solaris/SolarisCRT.h solaris/Battery.h
+endif
+
if HTOP_UNSUPPORTED
myhtopplatsources = unsupported/Platform.c \
unsupported/UnsupportedProcess.c unsupported/UnsupportedProcessList.c \