summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsitkevij <1553398+sitkevij@users.noreply.github.com>2020-11-22 09:17:40 -0800
committersitkevij <1553398+sitkevij@users.noreply.github.com>2020-11-22 09:17:40 -0800
commitd7d381f01932806d47d3f21c26428654b591b9f6 (patch)
tree1387bfc70dbe5a4da6680ae9650087a09f5d32c6
parent2d7f73e16b654e7bf3f3622569858ba0728fcee1 (diff)
chore: bump clap to 2.33 and ansi_term 0.12
-rw-r--r--Cargo.lock25
-rw-r--r--Cargo.toml4
2 files changed, 19 insertions, 10 deletions
diff --git a/Cargo.lock b/Cargo.lock
index d69a29f..ea174b4 100644
--- a/Cargo.lock
+++ b/Cargo.lock
@@ -10,6 +10,15 @@ dependencies = [
]
[[package]]
+name = "ansi_term"
+version = "0.12.1"
+source = "registry+https://github.com/rust-lang/crates.io-index"
+checksum = "d52a9bb7ec0cf484c551830a7ce27bd20d67eac647e1befb56b0be4ee39a55d2"
+dependencies = [
+ "winapi",
+]
+
+[[package]]
name = "assert_cmd"
version = "1.0.1"
source = "registry+https://github.com/rust-lang/crates.io-index"
@@ -41,11 +50,11 @@ checksum = "228047a76f468627ca71776ecdebd732a3423081fcf5125585bcd7c49886ce12"
[[package]]
name = "clap"
-version = "2.32.0"
+version = "2.33.3"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "b957d88f4b6a63b9d70d5f454ac8011819c6efa7727858f458ab71c756ce2d3e"
+checksum = "37e58ac78573c40708d45522f0d80fa2f01cc4f9b4e2bf749807255454312002"
dependencies = [
- "ansi_term",
+ "ansi_term 0.11.0",
"atty",
"bitflags",
"strsim",
@@ -70,7 +79,7 @@ checksum = "fea41bba32d969b513997752735605054bc0dfa92b4c56bf1189f2e174be7a10"
name = "hx"
version = "0.4.0"
dependencies = [
- "ansi_term",
+ "ansi_term 0.12.1",
"assert_cmd",
"atty",
"clap",
@@ -132,9 +141,9 @@ dependencies = [
[[package]]
name = "strsim"
-version = "0.7.0"
+version = "0.8.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "bb4f380125926a99e52bc279241539c018323fab05ad6368b56f93d9369ff550"
+checksum = "8ea5119cdb4c55b55d432abb513a0429384878c15dde60cc77b1c99de1a95a6a"
[[package]]
name = "termion"
@@ -149,9 +158,9 @@ dependencies = [
[[package]]
name = "textwrap"
-version = "0.10.0"
+version = "0.11.0"
source = "registry+https://github.com/rust-lang/crates.io-index"
-checksum = "307686869c93e71f94da64286f9a9524c0f308a9e1c87a583de8e9c9039ad3f6"
+checksum = "d326610f408c7a4eb6f51c37c330e496b08506c9457c9d34287ecc38809fb060"
dependencies = [
"unicode-width",
]
diff --git a/Cargo.toml b/Cargo.toml
index c78e35b..5e9965e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -26,8 +26,8 @@ panic = 'unwind' # panic strategy (`-C panic=...`), can also be 'abort'
opt-level = 3
[dependencies]
-clap = "2.31.1"
-ansi_term = "0.11"
+clap = "2.33"
+ansi_term = "0.12"
atty = "0.2"
no_color = "0.1"