summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlessio Sergi <al3hex@gmail.com>2017-01-21 18:08:16 +0100
committerAlessio Sergi <al3hex@gmail.com>2017-01-21 18:08:16 +0100
commit5988a655d3c6661566dbb6b97217934e49ae1908 (patch)
tree8b7c32e8d57cca78adb5a8135be43be7e3503b60 /setup.py
parent6ea077b197685dfd31cebb2261654252a695d404 (diff)
Fix installation under Windows, bottle is now mandatory.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 9 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 25af9633..f5a0c750 100755
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,14 @@ def get_data_files():
return data_files
+def get_install_requires():
+ requires = ['psutil>=2.0.0']
+ if sys.platform.startswith('win'):
+ requires.append('bottle')
+
+ return requires
+
+
class tests(Command):
user_options = []
@@ -68,7 +76,7 @@ setup(
url='https://github.com/nicolargo/glances',
license="LGPL",
keywords="cli curses monitoring system",
- install_requires=['psutil>=2.0.0'],
+ install_requires=get_install_requires(),
extras_require={
'ACTION': ['pystache'],
'BATINFO': ['batinfo'],