summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorasergi <al3hex@gmail.com>2012-07-07 17:47:47 +0200
committerasergi <al3hex@gmail.com>2012-07-07 17:47:47 +0200
commitf620472e00597554fe2978aab52432a3575ebd54 (patch)
tree06ccf7963a91a8084a390c3b675beae15c9b7a28 /setup.py
parentb52c27d236f570dcb8d36a869a886b8161f7614f (diff)
Fix setup.py
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py50
1 files changed, 25 insertions, 25 deletions
diff --git a/setup.py b/setup.py
index 7090cfef..9fd4b23a 100755
--- a/setup.py
+++ b/setup.py
@@ -8,35 +8,35 @@ from setuptools import setup
data_files = [
('share/man/man1', ['man/glances.1']),
('share/doc/glances', ['README',
- 'README-fr',
- 'COPYING',
- 'AUTHORS',
- 'NEWS',
- 'screenshot.png']),
+ 'README-fr',
+ 'COPYING',
+ 'AUTHORS',
+ 'NEWS',
+ 'screenshot.png']),
('share/doc/glances/doc', glob('doc/*.png')),
- ('share/glances/html', glob('src/html/*.html')),
- ('share/glances/html/css', glob('src/css/*.css')),
- ('share/glances/html/img', glob('src/img/*.png')),
+ ('share/glances/html', glob('glances/html/*.html')),
+ ('share/glances/css', glob('glances/css/*.css')),
+ ('share/glances/img', glob('glances/img/*.png')),
]
+
for mo in glob('i18n/*/LC_MESSAGES/*.mo'):
data_files.append((dirname(mo).replace('i18n/', 'share/locale/'), [mo]))
setup(name='Glances',
- version='1.4',
- download_url='https://github.com/downloads/nicolargo/glances/glances-1.4.tar.gz',
- url='https://github.com/nicolargo/glances',
- description='CLI curses-based monitoring tool',
- author='Nicolas Hennion',
- author_email='nicolas@nicolargo.com',
- license="LGPL",
- keywords="cli curses monitoring system",
- long_description=open('README').read(),
- install_requires=['psutil>=0.4.1'],
- packages=['glances'],
- extras_require = {
- 'HTML': ['jinja2>=2.0'],
- },
- include_package_data=True,
- data_files=data_files,
- entry_points={"console_scripts": ["glances = glances.glances:main"]},
+ version='1.4',
+ download_url='https://github.com/downloads/nicolargo/glances/glances-1.4.tar.gz',
+ url='https://github.com/nicolargo/glances',
+ description='CLI curses-based monitoring tool',
+ author='Nicolas Hennion',
+ author_email='nicolas@nicolargo.com',
+ license="LGPL",
+ keywords="cli curses monitoring system",
+ long_description=open('README').read(),
+ install_requires=['psutil>=0.4.1'],
+ packages=['glances'],
+ extras_require = {
+ 'HTML': ['jinja2>=2.0'],},
+ include_package_data=True,
+ data_files=data_files,
+ entry_points={"console_scripts": ["glances = glances.glances:main"]},
)